關於網路那些事...

網路行銷,SEO,網路趨勢,教學文章,網頁設計,生活時事

解決 vim-go requires Vim 7.4..but you're using an older version.

安裝 vim-go 之後,若開啟文件時,可能會遇到以下警示:

vim-go requires Vim 7.4.2009 or Neovim 0.3.2, but you're using an older version.
Please update your Vim for the best vim-go experience.
If you really want to continue you can set this to make the error go away:
let g:go_version_warning = 0
Note that some features may error out or behave incorrectly.
Please do not report bugs unless you're using Vim 7.4.2009 or newer or Neovim 0.3.2.
Press ENTER or type command to continue

但若直接查詢版本,可能會發現不論版本是 7.4 或以上版本都會出現這個錯誤,

vim --version

因此,常見處理方式如警示中所提,可直接將警示關掉
直接開啟 ~/.vimrc 文件
在最末端加入

let g:go_version_warning = 0

如果這篇文章對你有幫助,請在這裡點個讚



最新文章推薦